1C 8.3: Как записать и прочитать XML-файл - ЗУП по зубам - Всё для ЗУП 3.1 на 1С 8.3

1C 8.3: Как записать и прочитать XML-файл

Для обмена данными между разными конфигурациями можно использовать такие форматы, как txt, dbf, xls, xml и другие. В этой статье я расскажу вам, какие процедуры вам надо разместить в обработке для записи и чтения XML-файла.

Для записи XML-файла вставьте в свою обработку следующий код:

&НаСервере
Процедура ЗаписатьXML()

    ЗаписьXML = Новый ЗаписьXML;
 
    ЗаписьXML.ОткрытьФайл(ПолноеИмяФайла);
 
    ЗаписьXML.ЗаписатьОбъявлениеXML();    
 
    ЗаписьXML.ЗаписатьНачалоЭлемента("Запросы");
 
    Для Каждого СтрокаТЧ из Объект.ТЧ Цикл

		ЗаписьXML.ЗаписатьНачалоЭлемента("Запрос");
		ЗаписьXML.ЗаписатьАтрибут("ДатаЗапроса", СтрокаТЧ.ДатаЗапроса);
		ЗаписьXML.ЗаписатьАтрибут("НомерЗапроса", СтрокаТЧ.НомерЗапроса);

        ЗаписьXML.ЗаписатьКонецЭлемента(); // Запрос

    КонецЦикла;
 
    ЗаписьXML.ЗаписатьКонецЭлемента(); // Запросы
 
    ЗаписьXML.Закрыть();	
	
КонецПроцедуры

Для чтения XML-файла вставьте в свою обработку следующий код:

&НаСервере
Процедура ПрочитатьXML()

		ЗаписьXML = Новый ЧтениеXML;
		ЗаписьXML.ОткрытьФайл(ПолноеИмяФайла);
		
		Пока ЗаписьXML.Прочитать() Цикл
			Если ЗаписьXML.ТипУзла = ТипУзлаXML.НачалоЭлемента И ЗаписьXML.Имя = "Запрос" Тогда
				
				ДатаЗапроса = ЗаписьXML.ЗначениеАтрибута("ДатаЗапроса");
				НомерЗапроса = ЗаписьXML.ЗначениеАтрибута("НомерЗапроса");

                       КонецЕсли;
                КонецЦикла;

                ЗаписьXML.Закрыть();

КонецПроцедуры

Теперь вам по зубам написать обработку для записи и чтения XML-файла!

Добавить комментарий

Войти с помощью: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *