1С 8.3: Как программно вывести всех пользователей профиля - ЗУП по зубам - Всё для ЗУП 3.1 на 1С 8.3

1С 8.3: Как программно вывести всех пользователей профиля

Я расскажу вам, как с помощью внешней обработки вывести всех пользователей определенного профиля. Немного теории: в профиле указаны группы доступа, а в группах доступа указаны пользователи, которые в нее входят.

Создайте новую обработку, в которой добавьте реквизит «Профиль» со ссылкой на соответствующий справочник. На форме разместите кнопку и к ней пропишите команду «Проверить». В модуле обработки вставьте следующий код:

&НаСервере
Процедура ПроверитьНаСервере()
	
	Выборка=Справочники.ГруппыДоступа.Выбрать();
	Пока Выборка.Следующий() Цикл
		Если Выборка.Профиль=Объект.Профиль Тогда
			Сообщить(Выборка);
			Для Каждого СтрокаЮзеры из Выборка.Пользователи Цикл
				Сообщить(СтрокаЮзеры.Пользователь);
			КонецЦикла;
		КонецЕсли;
	КонецЦикла;	
	
КонецПроцедуры

&НаКлиенте
Процедура Проверить(Команда)
	ПроверитьНаСервере();
КонецПроцедуры

Теперь вам по зубам программный вывод всех пользователей выбранного профиля!

Добавить комментарий

Войти с помощью: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *