1С 8.3: Как выполнить внешнюю обработку в фоновом режиме по расписанию - ЗУП по зубам - Всё для ЗУП 3.1 на 1С 8.3

1С 8.3: Как выполнить внешнюю обработку в фоновом режиме по расписанию

Чтобы выполнить внешнюю обработку в фоновом режиме по расписанию в 1С 8.3 на управляемых формах, вставьте в модуль вашей обработки следующий код. Не забудьте в Функция СведенияОВнешнейОбработке() прописать строку ВызовСерверногоМетода.

Функция СведенияОВнешнейОбработке() Экспорт
  ПараметрыРегистрации = Новый Структура;
  ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
  ПараметрыРегистрации.Вставить("Наименование", "Тестовая обработка"); 
  ПараметрыРегистрации.Вставить("Версия", "1.0");
  ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
  ПараметрыРегистрации.Вставить("Информация", "Тестовая обработка"); 
  ПараметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
  ТаблицаКоманд = ПолучитьТаблицуКоманд();
  ДобавитьКоманду(ТаблицаКоманд,
  "Тестовая обработка", 
  "ТестоваяОбработка", 
  "ВызовСерверногоМетода");	
  ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
  Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции  

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт
  // Реализация логики команды
  Если ИдентификаторКоманды = "ТестоваяОбработка" Тогда
	  ВыполнитьТестовуюОбработкуНаСервере();
  КонецЕсли;
КонецПроцедуры

Процедура ВыполнитьТестовуюОбработкуНаСервере()
	// текст вашей обработки с учетом того, что вы находитесь на сервере	
КонецПроцедуры

После этого добавьте вашу обработку в пользовательском режиме  в «Дополнительные внешние обработки» и настройте расписание ее выполнения

Как выполнить внешнюю обработку в фоновом режиме по расписанию

Теперь вам по зубам запуск внешней обработки в фоновом режиме по расписанию в 1С 8.3 на управляемых формах!

Добавить комментарий

Войти с помощью: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *