Как на 1С 8.3 программно открыть форму списка документов (журнал) в режиме множественного выбора из внешней обработки | Форум Программирование в ЗУП 3.1

Форум

Добро пожаловать на «ЗУП по зубам» — Форум по ЗУП 3.1 на платформе 1С 8.3!

Задайте вопрос и специалисты-консультанты постараются вам помочь!

1 ответ(ов) в теме
ZupMan
не в сети 2 недели
На сайте с 16.03.2019
Администратор
Тем 141
Сообщения 241
1
13:58

Хочу поделиться кодом на 1С 8.3 (управляемые формы) как программно открыть форму списка документов (журнал) в режиме множественного выбора из внешней обработки. Добавьте на форму кнопку и укажите в ней команду "Подбор", далее в модуле формы пропишите:

&НаКлиенте
Процедура Подбор(Команда)
	ПараметрыФормы  = Новый Структура("РежимВыбора, ЗакрыватьПриВыборе,МножественныйВыбор", Истина, Истина,Истина);
	ОбработкаВыбора = Новый ОписаниеОповещения("ВыбратьДокументКонец", ЭтаФорма,);
	ОткрытьФорму("Документ.Отпуск.ФормаВыбора", ПараметрыФормы,
	ЭтаФорма, , , , ОбработкаВыбора);
КонецПроцедуры

&НаКлиенте
Процедура ВыбратьДокументКонец(Значение, ДопПараметры) Экспорт
	Если Значение = Неопределено Тогда
		Возврат;
	КонецЕсли;
	Для Индекс = 0 По Значение.Количество() - 1 Цикл
		СтрокаОтпуска=Объект.Отпуска.Добавить();
		СтрокаОтпуска.Отпуск=Значение[Индекс];
	КонецЦикла;
КонецПроцедуры

0
Вы не имеете права на публикацию сообщений в этой теме