Как программно получить норму дней или часов в 1с зуп 3.1? | Форум Программирование в ЗУП 3.1

Форум

Добро пожаловать на «ЗУП по зубам» — Форум по ЗУП 3.1 на платформе 1С 8.3!

Задайте вопрос и специалисты-консультанты постараются вам помочь!

1 ответ(ов) в теме
ZupMan
не в сети 6 часов
На сайте с 16.03.2019
Администратор
Тем 141
Сообщения 241
1
16:07

Чтобы программно получить норму дней или часов в 1с зуп 3.1, вставьте в свою внешнюю обработку следующий код:

    ДатаНачала=ДатаВывода;
    МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
		
    МассивСотрудников = Новый Массив;
    МассивСотрудников.Добавить(Сотрудник);
	
    СоздатьВТСотрудники(МенеджерВременныхТаблиц, МассивСотрудников, ДатаНачала);
	
    ПараметрыПолученияДанных = УчетРабочегоВремениРасширенный.ПараметрыПолученияДанныхУчетаВремени();
    ДатаНачала = ДатаВывода;
    ДатаОкончания = КонецМесяца(ДатаНачала);
    ПараметрыПолученияДанных.ДатаНачала = ДатаНачала;
	ПараметрыПолученияДанных.ДатаОкончания = ДатаОкончания;
	
	УчетРабочегоВремениРасширенный.СоздатьВТПлановоеВремя(МенеджерВременныхТаблиц, Истина, ПараметрыПолученияДанных);
	НормаТЗ = МенеджерВременныхТаблиц.Таблицы["ВТПлановоеВремя"].ПолучитьДанные().Выгрузить();
	ДниНорма=0;
	Для Каждого СтрокаНормаТЗ из НормаТЗ Цикл
		Если СокрЛП(СтрокаНормаТЗ.ВидУчетаВремени)="Явка" Тогда 
			Если Объект.СуммированныйУчетРабочегоВремени Тогда
				ДниНорма=ДниНорма+СтрокаНормаТЗ.ЧасыНорма;
			Иначе
				ДниНорма=ДниНорма+СтрокаНормаТЗ.ДниНорма;
			КонецЕсли;
		КонецЕсли;	
	КонецЦикла;	

0
Вы не имеете права на публикацию сообщений в этой теме