Как в расширении выполнить процедуру после типовой в 1с 8.3? | Форум Программирование в ЗУП 3.1

Форум

Добро пожаловать на «ЗУП по зубам» — Форум по ЗУП 3.1 на платформе 1С 8.3!

Задайте вопрос и специалисты-консультанты постараются вам помочь!

1 ответ(ов) в теме
ZupMan
не в сети 2 недели
На сайте с 16.03.2019
Администратор
Тем 141
Сообщения 241
1
10:23

Чтобы в расширении выполнить процедуру после типовой в 1с 8.3, вставьте следующий код в модуль формы документа

&НаСервере
&После("РассчитатьНачисленияНаСервере")
Процедура Расш1_РассчитатьНачисленияНаСервереПосле(ВыводитьСообщения = Ложь)
	Док=ЭтаФорма.РеквизитФормыВЗначение("Объект");
	НачисленияТЧ=Док.Начисления;
	Для Каждого СтрокаНачисленияТЧ из НачисленияТЧ Цикл
		ОтработаноЧасов=Окр(((КонецДня(СтрокаНачисленияТЧ.ДатаОкончания)-НачалоДня(СтрокаНачисленияТЧ.ДатаНачала))/86400)*8,0,1);
		Если СтрокаНачисленияТЧ.ОтработаноЧасов>ОтработаноЧасов Тогда
			Сообщить("Отработанные часы были скорректированы с "+СокрЛП(СтрокаНачисленияТЧ.ОтработаноЧасов)+" на "+СокрЛП(ОтработаноЧасов));
			СтрокаНачисленияТЧ.ОтработаноЧасов=ОтработаноЧасов;
			СтрокаНачисленияТЧ.ОплаченоЧасов=ОтработаноЧасов;
		КонецЕсли;	
	КонецЦикла;	
КонецПроцедуры

0
Вы не имеете права на публикацию сообщений в этой теме